blob: 3bfa20fcd92d57216c0b2f49c592835aac7c4fe0 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python bindings for interacting with systemd over DBus"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
4
5SRC_URI[sha256sum] = "4dcfa4b13a55685c49d3d17c10631eca18c33770f66316f8ef2337b8951cc144"
6
7DEPENDS = "systemd python3-cython-native"
8RDEPENDS:${PN} += "\
Patrick Williams39653562024-03-01 08:54:02 -06009 python3-xml \
10 python3-lxml \
11 python3-pprint \
12 python3-core \
13 python3-shell \
14 python3-io \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060015"
16REQUIRED_DISTRO_FEATURES = "systemd"
17
18inherit pypi setuptools3 features_check pkgconfig
19
20do_configure:prepend() {
21 rm -rf ${S}/pystemd/*.c
22}
23
24BBCLASSEXTEND = "native"