Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Python bindings for interacting with systemd over DBus" |
| 2 | LICENSE = "LGPL-2.1-only" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c" |
| 4 | |
| 5 | SRC_URI[sha256sum] = "4dcfa4b13a55685c49d3d17c10631eca18c33770f66316f8ef2337b8951cc144" |
| 6 | |
| 7 | DEPENDS = "systemd python3-cython-native" |
| 8 | RDEPENDS:${PN} += "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 9 | python3-xml \ |
| 10 | python3-lxml \ |
| 11 | python3-pprint \ |
| 12 | python3-core \ |
| 13 | python3-shell \ |
| 14 | python3-io \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 15 | " |
| 16 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 17 | |
| 18 | inherit pypi setuptools3 features_check pkgconfig |
| 19 | |
| 20 | do_configure:prepend() { |
| 21 | rm -rf ${S}/pystemd/*.c |
| 22 | } |
| 23 | |
| 24 | BBCLASSEXTEND = "native" |