Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "PyZMQ: Python bindings for ZMQ" |
| 2 | DESCRIPTION = "This package contains Python bindings for ZeroMQ. ZMQ is a lightweight and fast messaging implementation." |
| 3 | HOMEPAGE = "http://zeromq.org/bindings:python" |
| 4 | LICENSE = "BSD-3-Clause & LGPL-3.0-only" |
| 5 | LIC_FILES_CHKSUM = "\ |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 6 | file://LICENSE.BSD;md5=1787206f198344195a671b60326c59dc \ |
| 7 | file://LICENSE.LESSER;md5=0e99bfbdd8b9d33b0221986fe3be89ed \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 8 | " |
| 9 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 10 | DEPENDS = "python3-packaging-native python3-cython-native python3-setuptools-scm-native zeromq" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 11 | |
| 12 | SRC_URI:append = " \ |
| 13 | file://club-rpath-out.patch \ |
| 14 | file://run-ptest \ |
| 15 | " |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "93f1aa311e8bb912e34f004cf186407a4e90eec4f0ecc0efd26056bf7eda0226" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 17 | |
| 18 | inherit pypi pkgconfig python_setuptools_build_meta ptest |
| 19 | |
| 20 | PACKAGES =+ "\ |
| 21 | ${PN}-test \ |
| 22 | " |
| 23 | |
| 24 | FILES:${PN}-test += "\ |
| 25 | ${libdir}/${PYTHON_DIR}/site-packages/*/tests \ |
| 26 | " |
| 27 | |
| 28 | RDEPENDS:${PN} += "\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 29 | python3-json \ |
| 30 | python3-multiprocessing \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 31 | " |
| 32 | |
| 33 | RDEPENDS:${PN}-ptest += "\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 34 | ${PN}-test \ |
| 35 | python3-pytest \ |
| 36 | python3-unittest-automake-output \ |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 37 | python3-unixadmin \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 38 | " |
| 39 | |
| 40 | do_compile:prepend() { |
| 41 | echo [global] > ${S}/setup.cfg |
| 42 | echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg |
| 43 | echo have_sys_un_h = True >> ${S}/setup.cfg |
| 44 | echo skip_check_zmq = True >> ${S}/setup.cfg |
| 45 | echo libzmq_extension = False >> ${S}/setup.cfg |
| 46 | echo no_libzmq_extension = True >> ${S}/setup.cfg |
| 47 | } |
| 48 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 49 | do_install:append() { |
| 50 | sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/config.json |
| 51 | sed -i -e 's#${RECIPE_SYSROOT}##g' ${D}${PYTHON_SITEPACKAGES_DIR}/zmq/utils/compiler.json |
| 52 | } |
| 53 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 54 | do_install_ptest() { |
| 55 | install -d ${D}${PTEST_PATH}/tests |
| 56 | cp -rf ${S}/zmq/tests/* ${D}${PTEST_PATH}/tests/ |
| 57 | } |