blob: 81bffac3abf10f54eb9d1980cd3befb2a57df517 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001DESCRIPTION = "Pyzstd module provides classes and functions for compressing and \
2decompressing data, using Facebook’s Zstandard (or zstd as short name) algorithm."
3HOMEPAGE = "https://github.com/animalize/pyzstd"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=8458383225d7107f3383ee5c521628d2"
8
9PYPI_PACKAGE = "pyzstd"
10
Andrew Geissler8f840682023-07-21 09:09:43 -050011SRC_URI[sha256sum] = "cbfdde6c5768ffa5d2f14127bbc1d7c3c2d03c0ceaeb0736946197e06275ccc7"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050012
13inherit pypi setuptools3
Andrew Geissler3eeda902023-05-19 10:14:02 -050014
15# clang-16 with -flto segfaults on arm, therefore ignore flto for now
16do_configure:append:arm:toolchain-clang() {
17 sed -i -e "s|'-flto'|''|" ${S}/setup.py
18}