blob: d26a13dfbdcc197a90b8b52d269e64f9258dcda8 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "CSS selector library for python-beautifulsoup4"
2HOMEPAGE = "https://github.com/facelessuser/soupsieve"
3
4LICENSE = "MIT"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05005LIC_FILES_CHKSUM = "file://LICENSE.md;md5=520586fa71ed2cbda50b4a8c89621e09"
Andrew Geissler595f6302022-01-24 19:11:47 +00006
Andrew Geissler5082cc72023-09-11 08:41:39 -04007SRC_URI[sha256sum] = "5663d5a7b3bfaeee0bc4372e7fc48f9cff4940b3eec54a6451cc5299f1097690"
Andrew Geissler595f6302022-01-24 19:11:47 +00008
Andrew Geissler87f5cff2022-09-30 13:13:31 -05009inherit pypi python_hatchling python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +000010
11SRC_URI += " \
12 file://run-ptest \
13"
14
Andrew Geissler595f6302022-01-24 19:11:47 +000015RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 python3-beautifulsoup4 \
17 python3-pytest \
18 python3-unittest-automake-output \
Andrew Geissler595f6302022-01-24 19:11:47 +000019"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"