blob: 9dc7f793184995d2d7569c54c27fa57aac17bb1c [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05005
Patrick Williams2a254922023-08-11 09:48:11 -05006SRC_URI[sha256sum] = "cc3a47236ff05da377617ddefa867b7ba983819c664e1afe46249e5b469be464"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007
Patrick Williams2a254922023-08-11 09:48:11 -05008SRC_URI += " \
9 git://github.com/r1chardj0n3s/parse.git;branch=master;protocol=https \
10 file://run-ptest \
11"
12
13SRCREV ?= "72776522285d516032faa0f80c4ee6a8964075e8"
14
15S = "${WORKDIR}/git"
16
17inherit python_setuptools_build_meta ptest
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN} += "\
Patrick Williamsb542dec2023-06-09 01:26:37 -050020 python3-datetime \
21 python3-logging \
22 python3-numbers \
23"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050024
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN}-ptest += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050026 python3-pytest \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050027"
28
29do_install_ptest() {
Patrick Williamsb542dec2023-06-09 01:26:37 -050030 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
Andrew Geisslerc87764f2020-06-27 00:16:32 -050031}