blob: 49984f1125e519426d2db9eaa43e9ff22e29f202 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler220dafd2023-10-04 10:18:08 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
12 "
Andrew Geissler517393d2023-01-13 08:55:19 -060013
Andrew Geissler220dafd2023-10-04 10:18:08 -050014SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16# exclude betas
17UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
18
Andrew Geissler8f840682023-07-21 09:09:43 -050019CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
Andrew Geissler517393d2023-01-13 08:55:19 -060020
21inherit autotools multilib_header
22
23CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
24
25PACKAGECONFIG ?= "cxx jpeg zlib lzma \
26 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
27
28PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
29PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
30PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
31PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
32PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
33PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
Patrick Williams864cc432023-02-09 14:54:44 -060034PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
35PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
Andrew Geissler517393d2023-01-13 08:55:19 -060036
37# Convert single-strip uncompressed images to multiple strips of specified
38# size (default: 8192) to reduce memory usage
39PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
40
41# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
42PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
43
44# Control picking up YCbCr subsample info. Disable to support files lacking
45# the tag
46PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
47
48# Support a mechanism allowing reading large strips (usually one strip files)
49# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
50PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
51
52PACKAGES =+ "tiffxx tiff-utils"
53FILES:tiffxx = "${libdir}/libtiffxx.so.*"
54FILES:tiff-utils = "${bindir}/*"
55
56do_install:append() {
57 oe_multilib_header tiffconf.h
58}
59
60BBCLASSEXTEND = "native nativesdk"