blob: da99d65058d4035def0bc4170268a690be1f8a8f [file] [log] [blame]
Lancelot Kao4357d532021-02-22 15:20:35 -06001SUMMARY = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
Willy Tudec3caa2024-03-15 20:50:29 +000011PROVIDES:append = " virtual/bios-update"
12RPROVIDES:${PN}:append = " virtual/bios-update"
13
Lancelot Kao4357d532021-02-22 15:20:35 -060014DEPENDS += "systemd"
15DEPENDS += "phosphor-ipmi-flash"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050016RDEPENDS:${PN} += "libsystemd"
17RDEPENDS:${PN} += "bash"
Lancelot Kao4357d532021-02-22 15:20:35 -060018
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050019FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
Lancelot Kao4357d532021-02-22 15:20:35 -060020
Ashwin Murali39041de2022-03-23 17:09:16 -050021SRC_URI += " \
Lancelot Kao4357d532021-02-22 15:20:35 -060022 file://phosphor-ipmi-flash-bios-update.service \
23 file://config-bios.json \
24 "
25
26SYSTEMD_PACKAGES = "${PN}"
Ashwin Murali39041de2022-03-23 17:09:16 -050027SYSTEMD_SERVICE:${PN} += " \
Lancelot Kao4357d532021-02-22 15:20:35 -060028 phosphor-ipmi-flash-bios-update.service \
29 "
30
31do_install () {
32 install -d ${D}${datadir}/phosphor-ipmi-flash
33 install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash
34 install -d ${D}${systemd_system_unitdir}
35 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir}
36}