blob: ff2499e504dfa81926540e749b502d676fe4a156 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001SUMMARY = "protobuf-c"
2DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C"
3HOMEPAGE = "http://code.google.com/p/protobuf-c/"
4SECTION = "console/tools"
5LICENSE = "Apache-2.0"
6
Patrick Williamse69d2352017-02-23 20:56:04 -06007LIC_FILES_CHKSUM = "file://LICENSE;md5=235c3195a3968524dc1524b4ebea0c0e"
Patrick Williamsd849ec72016-08-17 14:59:38 -05008
9COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
10
11DEPENDS = "protobuf protobuf-c-native"
12
Patrick Williamse69d2352017-02-23 20:56:04 -060013SRC_URI[md5sum] = "e544249c329391fff512c3874895cfbe"
14SRC_URI[sha256sum] = "846eb4846f19598affdc349d817a8c4c0c68fd940303e6934725c889f16f00bd"
15SRC_URI = "https://github.com/protobuf-c/protobuf-c/releases/download/v1.2.1/protobuf-c-1.2.1.tar.gz "
16#SRC_URI_append_class-target ="file://0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch"
Patrick Williamsd849ec72016-08-17 14:59:38 -050017
18inherit autotools pkgconfig
19
20BBCLASSEXTEND = "native nativesdk"
21
22do_configure_prepend_class-target() {
23 export PKG_CONFIG_PATH="${STAGING_LIBDIR_NATIVE}/pkgconfig:${PKG_CONFIG_PATH}"
24}
25
26do_install_append_class-native() {
27 install -m 755 ${B}/t/generated-code2/cxx-generate-packed-data ${D}/${bindir}
28}