Jie Yang | 720e4b0 | 2021-07-23 02:30:19 -0700 | [diff] [blame] | 1 | SUMMARY = "Extract CPU and Memory Inventory from SMSMBIOS Table and PECI" |
| 2 | DESCRIPTION = "This package parses SMBIOS tables, reads Intel CPU PIROM and PECI and provides a dedicated IPMI blob to receive SMBIOS tables sent from LinuxBoot" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/smbios-mdr" |
Jie Yang | 720e4b0 | 2021-07-23 02:30:19 -0700 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Jie Yang | 720e4b0 | 2021-07-23 02:30:19 -0700 | [diff] [blame] | 6 | DEPENDS += " \ |
| 7 | boost \ |
| 8 | systemd \ |
| 9 | sdbusplus \ |
| 10 | phosphor-dbus-interfaces \ |
| 11 | phosphor-logging \ |
| 12 | " |
Andrew Geissler | 9d140cf | 2024-06-15 02:51:01 -0500 | [diff] [blame] | 13 | SRCREV = "7190f3a326cadca9fd8382aa38a78405faf67ac5" |
Jonathan Doman | a0ecf98 | 2023-07-26 11:39:50 -0700 | [diff] [blame] | 14 | PACKAGECONFIG[smbios-no-dimm] = "-Ddimm-dbus=disabled,-Ddimm-dbus=enabled" |
Jonathan Doman | 1846331 | 2024-03-28 12:15:48 -0700 | [diff] [blame] | 15 | PACKAGECONFIG[cpuinfo] = "-Dcpuinfo=enabled,-Dcpuinfo=disabled,i2c-tools" |
| 16 | PACKAGECONFIG[cpuinfo-peci] = "-Dcpuinfo-peci=enabled,-Dcpuinfo-peci=disabled,libpeci" |
Jonathan Doman | a0ecf98 | 2023-07-26 11:39:50 -0700 | [diff] [blame] | 17 | PACKAGECONFIG[smbios-ipmi-blob] = "-Dsmbios-ipmi-blob=enabled,-Dsmbios-ipmi-blob=disabled,phosphor-ipmi-blobs" |
Josh Lehan | 6f6c4bd | 2024-01-27 22:49:50 -0800 | [diff] [blame] | 18 | PACKAGECONFIG[assoc-trim-path] = "-Dassoc-trim-path=enabled,-Dassoc-trim-path=disabled" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 19 | PV = "1.0+git${SRCPV}" |
| 20 | PR = "r1" |
Jie Yang | 720e4b0 | 2021-07-23 02:30:19 -0700 | [diff] [blame] | 21 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 22 | SRC_URI = "git://github.com/openbmc/smbios-mdr.git;branch=master;protocol=https" |
Jie Yang | 720e4b0 | 2021-07-23 02:30:19 -0700 | [diff] [blame] | 23 | |
| 24 | S = "${WORKDIR}/git" |
Jie Yang | 720e4b0 | 2021-07-23 02:30:19 -0700 | [diff] [blame] | 25 | SYSTEMD_SERVICE:${PN} += "smbios-mdrv2.service" |
| 26 | SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'cpuinfo', 'xyz.openbmc_project.cpuinfo.service', '', d)}" |
| 27 | |
Jonathan Doman | a0ecf98 | 2023-07-26 11:39:50 -0700 | [diff] [blame] | 28 | inherit meson pkgconfig systemd |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 29 | |
Jonathan Doman | a0ecf98 | 2023-07-26 11:39:50 -0700 | [diff] [blame] | 30 | FILES:${PN} += "${libdir}/blob-ipmid" |