Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Crypto and TLS for C++11" |
| 2 | HOMEPAGE = "https://botan.randombit.net" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://license.txt;md5=a02e03c8fa2c5e7b9b3fcc1b9811fd3b" |
| 5 | SECTION = "libs" |
| 6 | |
| 7 | SRC_URI = "https://botan.randombit.net/releases/Botan-${PV}.tar.xz" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 8 | SRC_URI[sha256sum] = "f8c7b46222a857168a754a5cc329bb780504122b270018dda5304c98db28ae29" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | S = "${WORKDIR}/Botan-${PV}" |
| 11 | |
| 12 | inherit python3native siteinfo lib_package |
| 13 | |
| 14 | CPU ?= "${TARGET_ARCH}" |
| 15 | CPU_x86 = "x86_32" |
| 16 | CPU_armv7a = "armv7" |
| 17 | CPU_armv7ve = "armv7" |
| 18 | |
| 19 | do_configure() { |
| 20 | python3 ${S}/configure.py \ |
| 21 | --prefix="${D}${exec_prefix}" \ |
| 22 | --libdir="${D}${libdir}" \ |
| 23 | --cpu="${CPU}" \ |
| 24 | --cc-bin="${CXX}" \ |
| 25 | --cxxflags="${CXXFLAGS}" \ |
| 26 | --ldflags="${LDFLAGS}" \ |
| 27 | --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ |
| 28 | ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \ |
| 29 | --with-sysroot-dir=${STAGING_DIR_HOST} \ |
| 30 | --with-build-dir="${B}" \ |
| 31 | --optimize-for-size \ |
| 32 | --with-stack-protector \ |
| 33 | --enable-shared-library \ |
| 34 | --with-python-versions=3 \ |
| 35 | ${EXTRA_OECONF} |
| 36 | } |
| 37 | |
| 38 | do_compile() { |
| 39 | oe_runmake |
| 40 | } |
| 41 | do_install() { |
| 42 | oe_runmake install |
| 43 | sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc |
| 44 | } |
| 45 | |
| 46 | PACKAGES += "${PN}-python3" |
| 47 | |
| 48 | FILES_${PN}-python3 = "${libdir}/python3" |
| 49 | |
| 50 | RDEPENDS_${PN}-python3 += "python3" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 51 | |
| 52 | COMPATIBLE_HOST_riscv32 = "null" |