Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "YANG data modeling language library" |
| 2 | DESCRIPTION = "libyang is a YANG data modelling language parser and toolkit written (and providing API) in C." |
| 3 | HOMEPAGE = "https://github.com/CESNET/libyang" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f3916d7d8d42a6508d0ea418cfff10ad" |
| 8 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 9 | SRCREV = "87375f15159545a87a1e0de200f5d9d67e9091d7" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "git://github.com/CESNET/libyang.git;branch=master;protocol=https \ |
| 12 | file://libyang-add-stdint-h.patch \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | # Due to valgrind not supported on these arches: |
| 19 | COMPATIBLE_HOST:riscv32 = "null" |
| 20 | COMPATIBLE_HOST:armv5 = "null" |
| 21 | COMPATIBLE_HOST:riscv64 = "null" |
| 22 | |
| 23 | # Main dependencies |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 24 | inherit cmake pkgconfig lib_package ptest |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 25 | DEPENDS = "libpcre2" |
| 26 | DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'cmocka', '', d)}" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 27 | |
| 28 | # Ptest dependencies |
| 29 | RDEPENDS:${PN}-ptest += "valgrind" |
| 30 | |
| 31 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release" |
| 32 | EXTRA_OECMAKE += " ${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_TESTS=ON', '', d)}" |
| 33 | |
| 34 | do_install_ptest () { |
| 35 | cp -fR ${B}/tests/ ${D}${PTEST_PATH}/ |
| 36 | } |
| 37 | |