Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Gstreamer Daemon" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 2 | SUMMARY = "GStreamer framework for controlling audio and video streaming using TCP connection messages" |
| 3 | HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=Gstd-1.0" |
| 4 | SECTION = "multimedia" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-or-later" |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 8 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gstreamer1.0-rtsp-server json-glib libdaemon jansson" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | |
| 10 | SRCBRANCH ?= "master" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 11 | SRCREV = "a6621a5778b234651aa2adbbe304d906a3fa64d1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | SRC_URI = "git://git@github.com/RidgeRun/gstd-1.x.git;protocol=https;branch=${SRCBRANCH} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | file://0001-gstd-yocto-compatibility.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 17 | # Remove the +really when upstream version is > 1.0 |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 18 | PV = "1.0+really0.8.0" |
Brad Bishop | 93c3acf | 2019-10-29 09:48:15 -0400 | [diff] [blame] | 19 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | inherit autotools pkgconfig gettext gtk-doc |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | do_install:append() { |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 23 | rmdir ${D}${localstatedir}/run/${BPN} ${D}${localstatedir}/run \ |
| 24 | ${D}${localstatedir}/log/${BPN} ${D}${localstatedir}/log |
| 25 | rm -f ${D}${bindir}/gst-client ${D}${bindir}/gstd-client |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 26 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 27 | install -d ${D}${sysconfdir}/tmpfiles.d |
| 28 | echo "d /run/${BPN} - - - -" \ |
| 29 | > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf |
| 30 | echo "d /${localstatedir}/log/${BPN} 0755 root root -" \ |
| 31 | >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf |
| 32 | fi |
| 33 | ln -sf gst-client-1.0 ${D}${bindir}/gst-client |
| 34 | ln -sf gst-client-1.0 ${D}${bindir}/gstd-client |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | } |