blob: 610479b85d187ad673be4561c17e8d885a065e17 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# grub-efi.bbclass
2# Copyright (c) 2011, Intel Corporation.
3# All rights reserved.
4#
5# Released under the MIT license (see packages/COPYING)
6
7# Provide grub-efi specific functions for building bootable images.
8
9# External variables
10# ${INITRD} - indicates a list of filesystem images to concatenate and use as an initrd (optional)
11# ${ROOTFS} - indicates a filesystem image to include as the root filesystem (optional)
12# ${GRUB_GFXSERIAL} - set this to 1 to have graphics and serial in the boot menu
13# ${LABELS} - a list of targets for the automatic config
14# ${APPEND} - an override list of append strings for each label
15# ${GRUB_OPTS} - additional options to add to the config, ';' delimited # (optional)
16# ${GRUB_TIMEOUT} - timeout before executing the deault label (optional)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017# ${GRUB_ROOT} - grub's root device.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19do_bootimg[depends] += "${MLPREFIX}grub-efi:do_deploy"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21GRUB_SERIAL ?= "console=ttyS0,115200"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050022GRUB_CFG_VM = "${S}/grub_vm.cfg"
23GRUB_CFG_LIVE = "${S}/grub_live.cfg"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024GRUB_TIMEOUT ?= "10"
25#FIXME: build this from the machine config
26GRUB_OPTS ?= "serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1"
27
28EFIDIR = "/EFI/BOOT"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050029GRUB_ROOT ?= "${ROOT}"
30APPEND ?= ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031
32# Need UUID utility code.
33inherit fs-uuid
34
35efi_populate() {
36 # DEST must be the root of the image so that EFIDIR is not
37 # nested under a top level directory.
38 DEST=$1
39
40 install -d ${DEST}${EFIDIR}
41
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042 GRUB_IMAGE="grub-efi-bootia32.efi"
43 DEST_IMAGE="bootia32.efi"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050044 if [ "${TARGET_ARCH}" = "x86_64" ]; then
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045 GRUB_IMAGE="grub-efi-bootx64.efi"
46 DEST_IMAGE="bootx64.efi"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050048 install -m 0644 ${DEPLOY_DIR_IMAGE}/${GRUB_IMAGE} ${DEST}${EFIDIR}/${DEST_IMAGE}
Patrick Williamsc0f7c042017-02-23 20:41:17 -060049 EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050 printf 'fs0:%s\%s\n' "$EFIPATH" "$DEST_IMAGE" >${DEST}/startup.nsh
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050052 install -m 0644 ${GRUB_CFG} ${DEST}${EFIDIR}/grub.cfg
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053}
54
55efi_iso_populate() {
56 iso_dir=$1
57 efi_populate $iso_dir
58 # Build a EFI directory to create efi.img
59 mkdir -p ${EFIIMGDIR}/${EFIDIR}
60 cp $iso_dir/${EFIDIR}/* ${EFIIMGDIR}${EFIDIR}
61 cp $iso_dir/vmlinuz ${EFIIMGDIR}
Patrick Williamsf1e5d692016-03-30 15:21:19 -050062 EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g')
Patrick Williamsc0f7c042017-02-23 20:41:17 -060063 printf 'fs0:%s\%s\n' "$EFIPATH" "$GRUB_IMAGE" > ${EFIIMGDIR}/startup.nsh
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064 if [ -f "$iso_dir/initrd" ] ; then
65 cp $iso_dir/initrd ${EFIIMGDIR}
66 fi
67}
68
69efi_hddimg_populate() {
70 efi_populate $1
71}
72
73python build_efi_cfg() {
74 import sys
75
Brad Bishop6e60e8b2018-02-01 10:27:11 -050076 workdir = d.getVar('WORKDIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077 if not workdir:
78 bb.error("WORKDIR not defined, unable to package")
79 return
80
Brad Bishop6e60e8b2018-02-01 10:27:11 -050081 gfxserial = d.getVar('GRUB_GFXSERIAL') or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050082
Brad Bishop6e60e8b2018-02-01 10:27:11 -050083 labels = d.getVar('LABELS')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 if not labels:
85 bb.debug(1, "LABELS not defined, nothing to do")
86 return
87
88 if labels == []:
89 bb.debug(1, "No labels, nothing to do")
90 return
91
Brad Bishop6e60e8b2018-02-01 10:27:11 -050092 cfile = d.getVar('GRUB_CFG')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050093 if not cfile:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060094 bb.fatal('Unable to read GRUB_CFG')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050095
96 try:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060097 cfgfile = open(cfile, 'w')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050098 except OSError:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060099 bb.fatal('Unable to open %s' % cfile)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500100
101 cfgfile.write('# Automatically created by OE\n')
102
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500103 opts = d.getVar('GRUB_OPTS')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500104 if opts:
105 for opt in opts.split(';'):
106 cfgfile.write('%s\n' % opt)
107
108 cfgfile.write('default=%s\n' % (labels.split()[0]))
109
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500110 timeout = d.getVar('GRUB_TIMEOUT')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500111 if timeout:
112 cfgfile.write('timeout=%s\n' % timeout)
113 else:
114 cfgfile.write('timeout=50\n')
115
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500116 root = d.getVar('GRUB_ROOT')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500117 if not root:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600118 bb.fatal('GRUB_ROOT not defined')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500119
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500120 if gfxserial == "1":
121 btypes = [ [ " graphics console", "" ],
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500122 [ " serial console", d.getVar('GRUB_SERIAL') or "" ] ]
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123 else:
124 btypes = [ [ "", "" ] ]
125
126 for label in labels.split():
127 localdata = d.createCopy()
128
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500129 overrides = localdata.getVar('OVERRIDES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500130 if not overrides:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600131 bb.fatal('OVERRIDES not defined')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500132
133 for btype in btypes:
134 localdata.setVar('OVERRIDES', label + ':' + overrides)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500135
136 cfgfile.write('\nmenuentry \'%s%s\'{\n' % (label, btype[0]))
137 lb = label
138 if label == "install":
139 lb = "install-efi"
140 cfgfile.write('linux /vmlinuz LABEL=%s' % (lb))
141
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500142 cfgfile.write(' %s' % replace_rootfs_uuid(d, root))
143
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500144 append = localdata.getVar('APPEND')
145 initrd = localdata.getVar('INITRD')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500146
147 if append:
148 append = replace_rootfs_uuid(d, append)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600149 cfgfile.write(' %s' % (append))
150
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500151 cfgfile.write(' %s' % btype[1])
152 cfgfile.write('\n')
153
154 if initrd:
155 cfgfile.write('initrd /initrd')
156 cfgfile.write('\n}\n')
157
158 cfgfile.close()
159}