Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
| 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "d93adc48ceeb33347eb24a634fb787efc7ae4644e6ea4ba733d099605045c049" |
| 8 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 9 | SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch \ |
| 10 | file://0001-Fix-Cython-3-compatibility.patch" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 11 | |
| 12 | inherit pkgconfig pypi setuptools3 |
| 13 | |
| 14 | BBCLASSEXTEND = "native" |
| 15 | |
| 16 | DEPENDS = "python3-pkgconfig-native \ |
| 17 | python3-cython-native \ |
| 18 | python3-numpy-native \ |
| 19 | python3-six-native \ |
| 20 | hdf5-native \ |
| 21 | python3 \ |
| 22 | hdf5 \ |
| 23 | " |
| 24 | |
| 25 | PACKAGESPLITFUNCS =+ "fix_cythonized_sources" |
| 26 | |
| 27 | fix_cythonized_sources() { |
| 28 | for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}${TARGET_DBGSRC_DIR}`; do |
| 29 | if [ -e $f ]; then |
| 30 | sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f |
| 31 | fi |
| 32 | done |
| 33 | } |
| 34 | |
| 35 | RDEPENDS:${PN} = "python3-numpy \ |
| 36 | python3-six \ |
| 37 | python3-json \ |
| 38 | " |
| 39 | |
| 40 | export HDF5_VERSION="1.14.0" |