blob: 3945798ba5e3d7c57f116a5e57506385a3ee3273 [file] [log] [blame]
Patrick Williams705982a2024-01-12 09:51:57 -06001SUMMARY = "Classes Without Boilerplate"
2HOMEPAGE = "http://www.attrs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5e55731824cf9205cfabeab9a0600887"
5
6SRC_URI[sha256sum] = "935dc3b529c262f6cf76e50877d35a4bd3c1de194fd41f47a2b7ae8f19971f30"
7
8inherit pypi ptest python_hatchling
9
10SRC_URI += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060011 file://0001-test_funcs-skip-test_unknown-for-pytest-8.patch \
Patrick Williams705982a2024-01-12 09:51:57 -060012 file://run-ptest \
13"
14
15DEPENDS += " \
16 python3-hatch-vcs-native \
17 python3-hatch-fancy-pypi-readme-native \
18"
19
20RDEPENDS:${PN}+= " \
21 python3-compression \
22 python3-ctypes \
23 python3-crypt \
24"
25
26RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060027 python3-hypothesis \
28 python3-pytest \
29 python3-unittest-automake-output \
Patrick Williams705982a2024-01-12 09:51:57 -060030"
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/tests
34 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
35 install ${S}/conftest.py ${D}${PTEST_PATH}/
36}
37
38BBCLASSEXTEND = "native nativesdk"