Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Universal encoding detector for Python 2 and 3" |
| 2 | HOMEPAGE = "https://pypi.org/project/chardet/" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c" |
| 5 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "1b3b6ff479a8c414bc3fa2c0852995695c4a026dcd6d0633b2dd092ca39c1cf7" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 7 | |
| 8 | # setup.py of chardet needs this. |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame^] | 9 | DEPENDS += "python3-pytest-runner-native" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | |
| 11 | inherit pypi python_setuptools_build_meta |
| 12 | |
| 13 | PACKAGES =+ "${PN}-cli" |
| 14 | FILES:${PN}-cli += " \ |
| 15 | ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN}-cli = "${PN} " |
| 19 | |
| 20 | RDEPENDS:${PN}:class-target += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame^] | 21 | python3-logging \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |