Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 1 | DESCRIPTION = "IMA/EVM control utility" |
| 2 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | DEPENDS += "openssl attr keyutils" |
| 6 | |
| 7 | DEPENDS:class-native += "openssl-native keyutils-native" |
| 8 | |
Andrew Geissler | dc9d614 | 2023-05-19 09:38:37 -0500 | [diff] [blame] | 9 | FILESEXTRAPATHS:append := "${THISDIR}/${PN}:" |
| 10 | |
| 11 | SRC_URI = " \ |
| 12 | https://github.com/mimizohar/ima-evm-utils/releases/download/v${PV}/${BP}.tar.gz \ |
| 13 | file://0001-Do-not-get-generation-using-ioctl-when-evm_portable-.patch \ |
| 14 | " |
| 15 | SRC_URI[sha256sum] = "45f1caa3ad59ec59a1d6a74ea5df38c413488cd952ab62d98cf893c15e6f246d" |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 16 | |
| 17 | inherit pkgconfig autotools features_check |
| 18 | |
| 19 | REQUIRED_DISTRO_FEATURES = "ima" |
| 20 | REQUIRED_DISTRO_FEATURES:class-native = "" |
| 21 | |
Andrew Geissler | 2daf84b | 2023-03-31 09:57:23 -0500 | [diff] [blame] | 22 | EXTRA_OECONF += "MANPAGE_DOCBOOK_XSL=0" |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 23 | EXTRA_OECONF:append:class-target = " --with-kernel-headers=${STAGING_KERNEL_BUILDDIR}" |
| 24 | |
| 25 | # blkid is called by evmctl when creating evm checksums. |
| 26 | # This is less useful when signing files on the build host, |
| 27 | # so disable it when compiling on the host. |
| 28 | RDEPENDS:${PN}:append:class-target = " util-linux-blkid libcrypto attr libattr keyutils" |
| 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |