blob: ec36a375a4f76008f30a420cbb7ff45b0297bbad [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Open client for Cisco AnyConnect VPN"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=243b725d71bb5df4a1e5920b344b86ad"
4
Brad Bishop19323692019-04-05 15:28:33 -04005SRC_URI = "git://git.infradead.org/users/dwmw2/openconnect.git"
Brad Bishopc8f47122019-06-24 09:36:18 -04006SRCREV = "ea73851969ae7a6ea54fdd2d2b8c94776af24b2a"
Brad Bishop19323692019-04-05 15:28:33 -04007
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008DEPENDS = "vpnc libxml2 krb5 gettext-native"
Brad Bishop19323692019-04-05 15:28:33 -04009RDEPENDS_${PN} = "bash python"
Patrick Williamsddad1a12017-02-23 20:36:32 -060010
11PACKAGECONFIG ??= "gnutls lz4 libproxy"
12
13# config defaults
14PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls,"
15PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
16PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy,"
17
18# not config defaults
19PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite,"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021S = "${WORKDIR}/git"
22
23inherit autotools pkgconfig
24
25EXTRA_OECONF += "--with-vpnc-script=${SYSROOT_DESTDIR}${sysconfdir}/vpnc/vpnc-script \
26 --disable-static"
Brad Bishop19323692019-04-05 15:28:33 -040027
28do_configure_append() {
29 # script has /usr/bin/python2 path hardcoded
30 sed -i -e 's=python2\.*=python=g' ${S}/trojans/tncc-wrapper.py
31}