Patrick Williams | b2e6a9b | 2017-02-23 20:31:26 -0600 | [diff] [blame] | 1 | SUMMARY = "U-boot boot scripts for Raspberry Pi" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 4 | COMPATIBLE_MACHINE = "rpi" |
| 5 | |
| 6 | DEPENDS = "u-boot-mkimage-native" |
| 7 | |
| 8 | SRC_URI = "file://boot.cmd" |
| 9 | |
| 10 | do_compile() { |
| 11 | mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr |
| 12 | } |
| 13 | |
| 14 | inherit deploy |
| 15 | |
| 16 | do_deploy() { |
| 17 | install -d ${DEPLOYDIR} |
| 18 | install -m 0644 boot.scr ${DEPLOYDIR} |
| 19 | } |
| 20 | |
| 21 | addtask do_deploy after do_compile before do_build |