blob: 1717085967a48d71662cfb5dd26fa33d60d73c96 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A TOML-0.4.0 parser/writer for Python"
2HOMEPAGE = "https://pypi.python.org/pypi/pytoml/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=cfff423699bdaef24331933ac4f56078"
6
7SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b"
8SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7"
9
10inherit pypi setuptools3 ptest
11
12BBCLASSEXTEND = "native nativesdk"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
Patrick Williams213cb262021-08-07 19:21:33 -050018RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-datetime \
20 python3-stringold \
Andrew Geissler7f40b712020-05-15 14:09:53 -050021 "
22
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060024 python3-pytest \
25 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/test
30 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
31}