blob: fa616cd5044a6863b8ad05bca29fa8ec0dc45154 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Python documentation generator"
Andrew Geissler517393d2023-01-13 08:55:19 -06002HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
Patrick Williams520786c2023-06-25 16:20:36 -05004LICENSE = "BSD-2-Clause & MIT"
Patrick Williamsb542dec2023-06-09 01:26:37 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb6ac1b115a1ed24a12d9f15b633993"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
Patrick Williams2a254922023-08-11 09:48:11 -05007SRC_URI[sha256sum] = "59b8e391f0768a96cd233e8300fe7f0a8dc2f64f83dc2a54336a9a84f428ff4e"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9inherit python_flit_core pypi
10
Andrew Geissler517393d2023-01-13 08:55:19 -060011do_install:append () {
12 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
13 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
14}
15
16RDEPENDS:${PN} = "\
17 python3-alabaster \
18 python3-babel \
19 python3-docutils \
20 python3-imagesize \
21 python3-jinja2 \
22 python3-packaging \
23 python3-pygments \
24 python3-requests \
25 python3-snowballstemmer \
26 python3-sphinxcontrib-applehelp \
27 python3-sphinxcontrib-devhelp \
28 python3-sphinxcontrib-htmlhelp \
29 python3-sphinxcontrib-jsmath \
30 python3-sphinxcontrib-qthelp \
31 python3-sphinxcontrib-serializinghtml \
32 "
33
34BBCLASSEXTEND = "native nativesdk"