blob: 5ab484d8a5e1cca10f51128d43a50746ddf5093a [file] [log] [blame]
Brad Bishop34ae6002019-04-08 15:21:03 -04001SUMMARY = "Fast Artificial Neural Network (FANN) Library"
2DESCRIPTION = "Fast Artificial Neural Network (FANN) Library is a free open source neural network library, which implements multilayer artificial neural networks in C with support for both fully connected and sparsely connected networks."
3HOMEPAGE = "https://github.com/libfann/fann"
4SECTION = "libs/devel"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=f14599a2f089f6ff8c97e2baa4e3d575"
8
9inherit cmake
10
11SRCREV ?= "7ec1fc7e5bd734f1d3c89b095e630e83c86b9be1"
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/libfann/fann.git;branch=master;protocol=https \
Brad Bishop34ae6002019-04-08 15:21:03 -040013 "
14
15PV = "2.2.0+git${SRCPV}"
16
17S = "${WORKDIR}/git"
Brad Bishope42b3e32020-01-15 22:08:42 -050018
19EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"