Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "C++/Boost Asio based websocket client/server library." |
| 2 | SECTION = "libs/network" |
| 3 | HOMEPAGE = "https://github.com/zaphoyd/websocketpp" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea" |
| 6 | |
| 7 | DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} " |
| 8 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https;branch=master \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | file://0001-cmake-Use-GNUInstallDirs.patch \ |
| 11 | file://855.patch \ |
| 12 | file://857.patch \ |
| 13 | file://0001-Correct-clang-compiler-flags.patch \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 14 | file://1024.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} " |
| 18 | |
| 19 | # this is an header only library, do not depend on the main package |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN}-dev = "" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | |
| 22 | # to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this: |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | # TOOLCHAIN_TARGET_TASK:append = " websocketpp-dev" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
| 25 | # tag 0.8.2 |
| 26 | SRCREV= "56123c87598f8b1dd471be83ca841ceae07f95ba" |
| 27 | |
| 28 | S = "${WORKDIR}/git" |
| 29 | |
| 30 | inherit cmake |
| 31 | |
| 32 | PACKAGES =+ "${PN}-examples" |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN}-examples = "${docdir}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | install -d ${D}${docdir}/${BPN} |
| 38 | cp -R ${S}/examples ${D}${docdir}/${BPN} |
| 39 | } |