Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Very high-quality data compression program" |
| 2 | DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \ |
| 3 | Huffman coding. Compression is generally considerably better than that achieved by more conventional \ |
| 4 | LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors." |
Brad Bishop | 220d553 | 2018-08-14 00:59:39 +0100 | [diff] [blame] | 5 | HOMEPAGE = "https://sourceware.org/bzip2/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | SECTION = "console/utils" |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 7 | LICENSE = "bzip2-1.0.6 & GPLv3+ & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib" |
| 8 | LICENSE_${PN} = "bzip2-1.0.6" |
| 9 | LICENSE_${PN}-dev = "bzip2-1.0.6" |
| 10 | LICENSE_${PN}-dbg = "bzip2-1.0.6" |
| 11 | LICENSE_${PN}-doc = "bzip2-1.0.6" |
| 12 | LICENSE_${PN}-src = "bzip2-1.0.6" |
| 13 | LICENSE_libbz2 = "bzip2-1.0.6" |
| 14 | LICENSE_${PN}-ptest = "bzip2-1.0.6 & GPLv3+ & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib" |
| 15 | |
| 16 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664 \ |
| 17 | file://${WORKDIR}/git/commons-compress/LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327 \ |
| 18 | file://${WORKDIR}/git/dotnetzip/License.txt;md5=9cb56871eed4e748c3bc7e8ff352a54f \ |
| 19 | file://${WORKDIR}/git/dotnetzip/License.zlib.txt;md5=cc421ccd22eeb2e5db6b79e6de0a029f \ |
| 20 | file://${WORKDIR}/git/go/LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707 \ |
| 21 | file://${WORKDIR}/git/lbzip2/COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 22 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 23 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 24 | SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \ |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 25 | git://sourceware.org/git/bzip2-tests.git;name=bzip2-tests \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 26 | file://configure.ac;subdir=${BP} \ |
| 27 | file://Makefile.am;subdir=${BP} \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 28 | file://run-ptest \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 29 | " |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 30 | SRC_URI[md5sum] = "67e051268d0c475ea773822f7500d0e5" |
| 31 | SRC_URI[sha256sum] = "ab5a03176ee106d3f0fa90e381da478ddae405918153cca248e682cd0c4a2269" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 33 | SRCREV_bzip2-tests = "f9061c030a25de5b6829e1abf373057309c734c0" |
| 34 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 35 | UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 36 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 37 | PACKAGES =+ "libbz2" |
| 38 | |
| 39 | CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64" |
| 40 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 41 | inherit autotools update-alternatives ptest relative_symlinks |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 42 | |
| 43 | ALTERNATIVE_PRIORITY = "100" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 44 | ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 45 | |
| 46 | #install binaries to bzip2-native under sysroot for replacement-native |
| 47 | EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}" |
| 48 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 49 | do_configure_prepend () { |
| 50 | sed -i -e "s|%BZIP2_VERSION%|${PV}|" ${S}/configure.ac |
| 51 | } |
| 52 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 53 | do_install_ptest () { |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 54 | install -d ${D}${PTEST_PATH}/bzip2-tests |
| 55 | cp -r ${WORKDIR}/git/commons-compress ${D}${PTEST_PATH}/bzip2-tests/commons-compress |
| 56 | cp -r ${WORKDIR}/git/dotnetzip ${D}${PTEST_PATH}/bzip2-tests/dotnetzip |
| 57 | cp -r ${WORKDIR}/git/go ${D}${PTEST_PATH}/bzip2-tests/go |
| 58 | cp -r ${WORKDIR}/git/lbzip2 ${D}${PTEST_PATH}/bzip2-tests/lbzip2 |
| 59 | cp -r ${WORKDIR}/git/pyflate ${D}${PTEST_PATH}/bzip2-tests/pyflate |
| 60 | cp ${WORKDIR}/git/README ${D}${PTEST_PATH}/bzip2-tests/ |
| 61 | cp ${WORKDIR}/git/run-tests.sh ${D}${PTEST_PATH}/bzip2-tests/ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 62 | sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile |
| 63 | } |
| 64 | |
| 65 | FILES_libbz2 = "${libdir}/lib*${SOLIBS}" |
| 66 | |
Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 67 | RDEPENDS_${PN}-ptest += "make bash" |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 68 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 69 | PROVIDES_append_class-native = " bzip2-replacement-native" |
| 70 | BBCLASSEXTEND = "native nativesdk" |