Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SECTION = "devel" |
| 2 | SUMMARY = "Linux Trace Toolkit KERNEL MODULE" |
| 3 | DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules" |
| 4 | HOMEPAGE = "https://lttng.org/" |
| 5 | LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4" |
| 7 | |
| 8 | inherit module |
| 9 | |
| 10 | include lttng-platforms.inc |
| 11 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 12 | SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \ |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 13 | file://0001-Fix-ASoC-snd_doc_dapm-on-linux-6.9-rc1.patch \ |
| 14 | file://0002-Fix-ASoC-add-component-to-set_bias_level-events-in-l.patch \ |
| 15 | file://0003-Fix-mm_compaction_migratepages-changed-in-linux-6.9-.patch \ |
| 16 | file://0004-Fix-dev_base_lock-removed-in-linux-6.9-rc1.patch \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 17 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 18 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 19 | # Use :append here so that the patch is applied also when using devupstream |
| 20 | SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch" |
| 21 | |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 22 | SRC_URI[sha256sum] = "d85fcb66c7bd31003ab8735e8c77700e5e4f417b4c22fe1f20112cf435abad79" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 23 | |
| 24 | export INSTALL_MOD_DIR="kernel/lttng-modules" |
| 25 | |
| 26 | EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'" |
| 27 | |
| 28 | MODULES_MODULE_SYMVERS_LOCATION = "src" |
| 29 | |
| 30 | do_install:append() { |
| 31 | # Delete empty directories to avoid QA failures if no modules were built |
| 32 | if [ -d ${D}/${nonarch_base_libdir} ]; then |
| 33 | find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \; |
| 34 | fi |
| 35 | } |
| 36 | |
| 37 | python do_package:prepend() { |
| 38 | if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')): |
| 39 | bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN')) |
| 40 | } |
| 41 | |
| 42 | BBCLASSEXTEND = "devupstream:target" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 43 | SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13;protocol=https" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 44 | SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630" |
| 45 | SRCREV_FORMAT ?= "lttng_git" |