Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A library for faking the system time in user-space programs" |
| 2 | SECTION = "libs" |
| 3 | LICENSE = "GPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 5 | |
| 6 | SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c" |
| 7 | |
| 8 | SRC_URI = "git://github.com/wolfcw/libfaketime.git;branch=master;protocol=https \ |
| 9 | file://0001-Makefile-Detect-compiler-in-makefile.patch \ |
| 10 | " |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE" |
| 15 | |
| 16 | do_configure[noexec] = "1" |
| 17 | do_compile () { |
| 18 | oe_runmake |
| 19 | } |
| 20 | do_install () { |
| 21 | install -d ${D}${libdir}/faketime |
| 22 | oe_libinstall -C src libfaketime ${D}${libdir}/faketime |
| 23 | install -d ${D}${bindir} |
| 24 | install -m 0755 src/faketime ${D}${bindir} |
| 25 | } |
| 26 | |
| 27 | FILES:${PN} = "${bindir}/faketime ${libdir}/faketime/lib*${SOLIBS}" |
| 28 | FILES:${PN}-dev += "${libdir}/faketime/lib*${SOLIBSDEV}" |