blob: f4ed0720ff6b29746177513ebb24e1576bf63336 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Python documentation generator"
Andrew Geissler517393d2023-01-13 08:55:19 -06002HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
Patrick Williams520786c2023-06-25 16:20:36 -05004LICENSE = "BSD-2-Clause & MIT"
Patrick Williamsb542dec2023-06-09 01:26:37 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb6ac1b115a1ed24a12d9f15b633993"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
Andrew Geissler220dafd2023-10-04 10:18:08 -05007SRC_URI[sha256sum] = "9a5160e1ea90688d5963ba09a2dcd8bdd526620edbb65c328728f1b2228d5ab5"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
9inherit python_flit_core pypi
Andrew Geissler5082cc72023-09-11 08:41:39 -040010UPSTREAM_CHECK_REGEX = "/Sphinx/(?P<pver>(\d+[\.\-_]*)+)/"
Andrew Geissler517393d2023-01-13 08:55:19 -060011
Andrew Geissler517393d2023-01-13 08:55:19 -060012do_install:append () {
13 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
14 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
15}
16
17RDEPENDS:${PN} = "\
18 python3-alabaster \
19 python3-babel \
20 python3-docutils \
21 python3-imagesize \
22 python3-jinja2 \
23 python3-packaging \
24 python3-pygments \
25 python3-requests \
26 python3-snowballstemmer \
27 python3-sphinxcontrib-applehelp \
28 python3-sphinxcontrib-devhelp \
29 python3-sphinxcontrib-htmlhelp \
30 python3-sphinxcontrib-jsmath \
31 python3-sphinxcontrib-qthelp \
32 python3-sphinxcontrib-serializinghtml \
33 "
34
35BBCLASSEXTEND = "native nativesdk"