Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 1 | SUMMARY = "PLDM Stack" |
| 2 | DESCRIPTION = "Implementation of the PLDM specifications" |
Tom Joseph | f6785aa | 2021-06-15 07:12:34 -0700 | [diff] [blame] | 3 | DEPENDS += "function2" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 4 | DEPENDS += "systemd" |
Matt Spinler | e2375b5 | 2020-01-20 14:09:47 -0600 | [diff] [blame] | 5 | DEPENDS += "sdeventplus" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 6 | DEPENDS += "phosphor-dbus-interfaces" |
| 7 | DEPENDS += "nlohmann-json" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 8 | DEPENDS += "cli11" |
Manojkiran Eda | c593475 | 2022-09-27 13:59:35 -0500 | [diff] [blame] | 9 | DEPENDS += "libpldm" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 10 | PV = "1.0+git${SRCPV}" |
| 11 | PR = "r1" |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 14 | SYSTEMD_SERVICE:${PN} += "pldmd.service" |
| 15 | SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service" |
Deepak Kodihalli | a748201 | 2020-06-22 05:25:35 -0500 | [diff] [blame] | 16 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 17 | inherit meson pkgconfig |
| 18 | inherit systemd |
| 19 | |
Deepak Kodihalli | 7a113ee | 2019-10-14 01:23:27 -0500 | [diff] [blame] | 20 | EXTRA_OEMESON = " \ |
| 21 | -Dtests=disabled \ |
| 22 | -Doem-ibm=disabled \ |
| 23 | " |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 24 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 25 | pkg_prerm:${PN} () { |
| 26 | LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service" |
| 27 | rm $LINK |
| 28 | LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service" |
| 29 | rm $LINK |
| 30 | } |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 31 | # Install pldmSoftPowerOff.service in correct targets |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 32 | pkg_postinst:${PN} () { |
Manojkiran Eda | 842eb7f | 2021-09-15 18:47:42 +0530 | [diff] [blame] | 33 | mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants |
| 34 | LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service" |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 35 | TARGET="../pldmSoftPowerOff.service" |
| 36 | ln -s $TARGET $LINK |
Manojkiran Eda | 842eb7f | 2021-09-15 18:47:42 +0530 | [diff] [blame] | 37 | mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants |
| 38 | LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service" |
Andrew Geissler | 0c3d0e2 | 2020-10-28 16:43:35 -0500 | [diff] [blame] | 39 | TARGET="../pldmSoftPowerOff.service" |
| 40 | ln -s $TARGET $LINK |
| 41 | } |
| 42 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 43 | require pldm.inc |