blob: 7060a643b8ba281f043f671bb53033ab1212d0db [file] [log] [blame]
Andrew Geisslercc589282020-09-18 13:34:40 -05001SUMMARY = "IBM's Software TPM 2.0"
2DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \
3education, and virtualization. \
4\
5The intent is that an application can be developed using the software TPM. \
6The application should then run using a hardware TPM without changes. \
7Advantages of this approach: \
8* In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \
9* Application software errors are easily reversed by simply removing the TPM state and starting over. \
10* Difficult crypto errors are quickly debugged by looking inside the TPM."
11HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html"
Andrew Geissler5199d832021-09-24 16:47:35 -050012LICENSE = "BSD-2-Clause"
Andrew Geisslercc589282020-09-18 13:34:40 -050013SECTION = "securty/tpm"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f"
Patrick Williamsb542dec2023-06-09 01:26:37 -050015LIC_FILES_CHKSUM += "file://LICENSE;md5=c75e465155c42c14154bf6a2acb7347b"
Andrew Geisslercc589282020-09-18 13:34:40 -050016
17DEPENDS = "openssl"
18
Patrick Williamsb542dec2023-06-09 01:26:37 -050019SRC_URI = "git://git.code.sf.net/p/ibmswtpm2/tpm2;protocol=https;branch=master \
Andrew Geisslercc589282020-09-18 13:34:40 -050020 file://tune-makefile.patch \
Andrew Geisslercc589282020-09-18 13:34:40 -050021 "
Patrick Williamsb542dec2023-06-09 01:26:37 -050022SRCREV = "5452af422edeff70fcae8ea99dd28a0922051d7b"
William A. Kennington IIIee32beb2021-06-02 12:48:35 -070023
Patrick Williamsb542dec2023-06-09 01:26:37 -050024UPSTREAM_CHECK_URI = "https://git.code.sf.net/p/ibmswtpm2/tpm2"
Andrew Geisslercc589282020-09-18 13:34:40 -050025
Patrick Williamsb542dec2023-06-09 01:26:37 -050026S = "${WORKDIR}/git/src"
Andrew Geisslercc589282020-09-18 13:34:40 -050027
Andrew Geissler8b139282021-03-05 15:22:30 -060028CFLAGS += "-Wno-error=maybe-uninitialized -DALG_CAMELLIA=ALG_NO"
Andrew Geisslercc589282020-09-18 13:34:40 -050029
30do_compile () {
31 make CC='${CC}'
32}
33
34do_install () {
35 install -d ${D}/${bindir}
36 install -m 0755 tpm_server ${D}/${bindir}
37}