Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM's Software TPM 2.0" |
| 2 | DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \ |
| 3 | education, and virtualization. \ |
| 4 | \ |
| 5 | The intent is that an application can be developed using the software TPM. \ |
| 6 | The application should then run using a hardware TPM without changes. \ |
| 7 | Advantages of this approach: \ |
| 8 | * In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \ |
| 9 | * Application software errors are easily reversed by simply removing the TPM state and starting over. \ |
| 10 | * Difficult crypto errors are quickly debugged by looking inside the TPM." |
| 11 | HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 12 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 13 | SECTION = "securty/tpm" |
| 14 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 15 | LIC_FILES_CHKSUM += "file://LICENSE;md5=c75e465155c42c14154bf6a2acb7347b" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 16 | |
| 17 | DEPENDS = "openssl" |
| 18 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 19 | SRC_URI = "git://git.code.sf.net/p/ibmswtpm2/tpm2;protocol=https;branch=master \ |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 20 | file://tune-makefile.patch \ |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 21 | " |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 22 | SRCREV = "5452af422edeff70fcae8ea99dd28a0922051d7b" |
William A. Kennington III | ee32beb | 2021-06-02 12:48:35 -0700 | [diff] [blame] | 23 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 24 | UPSTREAM_CHECK_URI = "https://git.code.sf.net/p/ibmswtpm2/tpm2" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 25 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 26 | S = "${WORKDIR}/git/src" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 27 | |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 28 | CFLAGS += "-Wno-error=maybe-uninitialized -DALG_CAMELLIA=ALG_NO" |
Andrew Geissler | cc58928 | 2020-09-18 13:34:40 -0500 | [diff] [blame] | 29 | |
| 30 | do_compile () { |
| 31 | make CC='${CC}' |
| 32 | } |
| 33 | |
| 34 | do_install () { |
| 35 | install -d ${D}/${bindir} |
| 36 | install -m 0755 tpm_server ${D}/${bindir} |
| 37 | } |