Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A fully featured modbus protocol stack in python" |
| 2 | HOMEPAGE = "https://github.com/riptideio/pymodbus/" |
| 3 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=430604f78bee72425da231d42eac9cee" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 5 | DEPENDS += "python3-six-native" |
| 6 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "82787121e293f31095c0e9721b3e561a01807a6ac20abcbfb187ce70d24fb40c" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 8 | S = "${WORKDIR}/pymodbus-${PV}" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | PACKAGECONFIG ??= "" |
| 13 | PACKAGECONFIG[repl] = ",,,python3-aiohttp python3-click python3-prompt-toolkit python3-pygments python3-pyserial-asyncio" |
| 14 | PACKAGECONFIG[asyncio] = ",,,python3-pyserial-asyncio" |
| 15 | PACKAGECONFIG[tornado] = ",,,python3-tornado" |
| 16 | PACKAGECONFIG[twisted] = ",,,python3-twisted-conch" |
| 17 | PACKAGECONFIG[redis] = ",,,python3-redis" |
| 18 | PACKAGECONFIG[sql] = ",,,python3-sqlalchemy" |
| 19 | |
| 20 | RDEPENDS:${PN} += " \ |
| 21 | python3-asyncio \ |
| 22 | python3-core \ |
| 23 | python3-io \ |
| 24 | python3-json \ |
| 25 | python3-logging \ |
| 26 | python3-math \ |
| 27 | python3-netserver \ |
| 28 | " |
| 29 | |
| 30 | RDEPENDS:${PN} += " \ |
| 31 | python3-pyserial \ |
| 32 | python3-six \ |
| 33 | " |
| 34 | |
| 35 | |