Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Cap'n Proto serialization/RPC system" |
| 2 | DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. " |
| 3 | HOMEPAGE = "https://github.com/sandstorm-io/capnproto" |
| 4 | SECTION = "console/tools" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | LICENSE = "MIT" |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 8 | SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-${PV} \ |
| 9 | file://0001-mutex-Fix-build-on-32-bit-architectures-using-64-bit.patch;patchdir=../ \ |
| 10 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 11 | SRCREV = "57a4ca5af5a7f55b768a9d9d6655250bffb1257f" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git/c++" |
| 14 | |
| 15 | inherit cmake |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | |
| 17 | EXTRA_OECMAKE += "\ |
| 18 | -DBUILD_TESTING=OFF \ |
| 19 | " |
| 20 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | FILES_${PN}-compiler = "${bindir}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | |
| 23 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 24 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 25 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | BBCLASSEXTEND = "native nativesdk" |