Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER" |
| 2 | DESCRIPTION = "A host control implementation suitable for OpenPOWER systems." |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 3 | PROVIDES += "virtual/obmc-host-ctl" |
Patrick Venture | c233b00 | 2018-10-09 20:20:36 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 5 | PR = "r1" |
| 6 | |
| 7 | SKELETON_DIR = "op-hostctl" |
| 8 | SYSTEMD_SERVICE:${PN} = " \ |
| 9 | op-start-host@.service \ |
| 10 | " |
| 11 | START_TMPL = "op-start-host@.service" |
| 12 | START_TGTFMT = "obmc-host-startmin@{1}.target" |
| 13 | START_INSTFMT = "op-start-host@{0}.service" |
| 14 | START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}" |
| 15 | SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}" |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 16 | |
| 17 | inherit skeleton-gdbus |
Brad Bishop | 1d525fa | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 18 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 9267362 | 2018-01-26 21:30:17 -0500 | [diff] [blame] | 19 | inherit pkgconfig |
Brad Bishop | 5f9be07 | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 20 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 21 | RPROVIDES:${PN} += "virtual-obmc-host-ctl" |
Sergey Solomin | aac4adf | 2016-11-28 15:03:24 -0600 | [diff] [blame] | 22 | |
Brad Bishop | 1d525fa | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 23 | FMT = "org.openbmc.control.Host@{0}.service" |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 24 | DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}" |