George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 1 | PR = "r1" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 4 | |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 5 | inherit systemd |
| 6 | inherit obmc-phosphor-systemd |
| 7 | |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 8 | SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \ |
| 9 | file://bmc-verify.sh \ |
| 10 | file://config-bmc.json \ |
| 11 | " |
| 12 | |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 13 | FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json" |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 14 | |
Brandon Kim | cf40682 | 2021-07-30 16:19:14 -0700 | [diff] [blame] | 15 | PROVIDES += "virtual/bmc-update" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 16 | RPROVIDES:${PN} += "virtual/bmc-update" |
Brandon Kim | cf40682 | 2021-07-30 16:19:14 -0700 | [diff] [blame] | 17 | |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 18 | DEPENDS += "systemd" |
| 19 | DEPENDS += "phosphor-ipmi-flash" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 20 | RDEPENDS:${PN} = "bash" |
George Hung | f089ba1 | 2020-05-20 17:22:25 +0800 | [diff] [blame] | 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}${bindir} |
| 24 | install -m 0755 ${WORKDIR}/bmc-verify.sh ${D}${bindir}/ |
| 25 | |
| 26 | install -d ${D}${systemd_system_unitdir} |
| 27 | install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmc-verify.service ${D}${systemd_system_unitdir} |
| 28 | |
| 29 | install -d ${D}${datadir}/phosphor-ipmi-flash |
| 30 | install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash |
| 31 | } |
| 32 | |
| 33 | |
| 34 | SYSTEMD_PACKAGES = "${PN}" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 35 | SYSTEMD_SERVICE:${PN} = "phosphor-ipmi-flash-bmc-verify.service" |