blob: be715de797dcb84f6864bef7bb536c25db5604bc [file] [log] [blame]
Lancelot Kao4357d532021-02-22 15:20:35 -06001SUMMARY = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Kudo BIOS Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050013RDEPENDS:${PN} += "libsystemd"
14RDEPENDS:${PN} += "bash"
Lancelot Kao4357d532021-02-22 15:20:35 -060015
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050016FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bios.json"
Lancelot Kao4357d532021-02-22 15:20:35 -060017
Ashwin Murali39041de2022-03-23 17:09:16 -050018SRC_URI += " \
Lancelot Kao4357d532021-02-22 15:20:35 -060019 file://phosphor-ipmi-flash-bios-update.service \
20 file://config-bios.json \
21 "
22
23SYSTEMD_PACKAGES = "${PN}"
Ashwin Murali39041de2022-03-23 17:09:16 -050024SYSTEMD_SERVICE:${PN} += " \
Lancelot Kao4357d532021-02-22 15:20:35 -060025 phosphor-ipmi-flash-bios-update.service \
26 "
27
28do_install () {
29 install -d ${D}${datadir}/phosphor-ipmi-flash
30 install -m 0644 ${WORKDIR}/config-bios.json ${D}${datadir}/phosphor-ipmi-flash
31 install -d ${D}${systemd_system_unitdir}
32 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bios-update.service ${D}${systemd_system_unitdir}
33}