Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "VA-API support to GStreamer" |
| 2 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ |
| 3 | based plugins for GStreamer and helper libraries: `vaapidecode', \ |
| 4 | `vaapiconvert', and `vaapisink'." |
| 5 | |
| 6 | REALPN = "gstreamer-vaapi" |
| 7 | |
| 8 | LICENSE = "LGPLv2.1+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 10 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 11 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 13 | SRC_URI[sha256sum] = "8c7b2c74fda095d83dea67accde6a68ba9f608d97ed969fdcf278930f9b1c7c0" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/${REALPN}-${PV}" |
| 16 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" |
| 17 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 18 | inherit meson pkgconfig features_check upstream-version-is-even |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | REQUIRED_DISTRO_FEATURES ?= "opengl" |
| 21 | |
| 22 | EXTRA_OEMESON += " \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 23 | -Ddoc=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | -Dexamples=disabled \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 25 | -Dtests=enabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | " |
| 27 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | PACKAGES =+ "${PN}-tests" |
| 29 | |
| 30 | # OpenGL packageconfig factored out to make it easy for distros |
| 31 | # and BSP layers to pick either glx, egl, or no GL. By default, |
| 32 | # try detecting X11 first, and if found (with OpenGL), use GLX, |
| 33 | # otherwise try to check if EGL can be used. |
| 34 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ |
| 35 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ |
| 36 | '', d), d)}" |
| 37 | |
| 38 | PACKAGECONFIG ??= "drm encoders \ |
| 39 | ${PACKAGECONFIG_GL} \ |
| 40 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 41 | |
| 42 | PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm" |
| 43 | PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl" |
| 44 | PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no" |
| 45 | PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl" |
| 46 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols" |
| 47 | PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender" |
| 48 | |
| 49 | FILES_${PN} += "${libdir}/gstreamer-*/*.so" |
| 50 | FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug" |
| 51 | FILES_${PN}-dev += "${libdir}/gstreamer-*/*.a" |
| 52 | FILES_${PN}-tests = "${bindir}/*" |