blob: 7343036807a24ba52c4652d82bee1053a381482d [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00005LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = " \
8 alsa-lib \
9 atk \
10 cairo \
11 fontconfig \
12 freetype \
13 gdk-pixbuf-native \
14 intltool-native \
15 libxslt-native \
16 gegl-native \
17 dbus-glib \
18 gtk+ \
19 babl \
20 gegl \
21 libmypaint \
22 mypaint-brushes-1.0 \
23 gexiv2 \
24 jpeg \
25 libmng \
26 libpng \
27 libexif \
28 tiff \
29 lcms \
30 poppler \
31 poppler-data \
32 jasper \
33 bzip2 \
34 libgudev \
35 libmng \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \
37"
38DEPENDS:append:libc-musl = " libexecinfo"
39
40inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg
41
42REQUIRED_DISTRO_FEATURES = "x11"
43
44SHPV = "${@gnome_verdir("${PV}")}"
45
Patrick Williamse760df82023-05-26 11:10:49 -050046SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2 \
47 file://0001-configure-Keep-first-line-of-compiler-version-string.patch \
48 file://0001-libtool-Do-not-add-build-time-library-paths-to-LD_LI.patch"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050049SRC_URI[sha256sum] = "84004642d351b398a4293cd7fd3592044a944f05bb52850ee6068f247c657aa3"
Andrew Geissler595f6302022-01-24 19:11:47 +000050
51EXTRA_OECONF = "--disable-python \
52 --without-webkit \
53 --disable-check-update \
54 --without-wmf"
55
Patrick Williams03907ee2022-05-01 06:28:52 -050056EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '32', ' --disable-vector-icons', '', d)}"
Andrew Geissler595f6302022-01-24 19:11:47 +000057
58do_configure:append() {
59 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
60 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
61}
62
63do_compile:prepend() {
64 # Let native babl/gegl find their plugins
65 export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'`
66 export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'`
67}
68
69FILES:${PN} += "${datadir}/metainfo"
70
71RDEPENDS:${PN} += "mypaint-brushes-1.0"