blob: 0634b3424293e3f2812fd1acd34a73e0fed9197d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001BPN = "qemu"
2
Andrew Geisslereff27472021-10-29 15:35:00 -05003require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
Patrick Williams169d7bc2024-01-05 11:33:25 -06008DEPENDS += "glib-2.0-native zlib-native pixman-native qemu-native"
Andrew Geisslereff27472021-10-29 15:35:00 -05009
10EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
11
Andrew Geissler5082cc72023-09-11 08:41:39 -040012PACKAGECONFIG ??= "fdt alsa kvm pie slirp png \
Andrew Geissler9aee5002022-03-30 16:27:02 +000013 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer epoxy', '', d)} \
Andrew Geisslereff27472021-10-29 15:35:00 -050014"
15
16# Handle distros such as CentOS 5 32-bit that do not have kvm support
17PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
18
19do_install:append() {
20 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
21
22 # The following is also installed by qemu-native
23 rm -f ${D}${datadir}/qemu/trace-events-all
24 rm -rf ${D}${datadir}/qemu/keymaps
25 rm -rf ${D}${datadir}/icons/
26 rm -rf ${D}${includedir}/qemu-plugin.h
27
28 # Install qmp.py to be used with testimage
Andrew Geissler87f5cff2022-09-30 13:13:31 -050029 install -d ${D}${libdir}/qemu-python/qmp/
30 install -D ${S}/python/qemu/qmp/* ${D}${libdir}/qemu-python/qmp/
Andrew Geisslereff27472021-10-29 15:35:00 -050031}