Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 1 | SUMMARY = "A suite of libcamera-based apps" |
| 2 | DESCRIPTION = "This is a small suite of libcamera-based apps that aim to \ |
| 3 | copy the functionality of the existing \"raspicam\" apps." |
| 4 | HOMEPAGE = "https://github.com/raspberrypi/libcamera-apps" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://license.txt;md5=a0013d1b383d72ba4bdc5b750e7d1d77" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | git://github.com/raspberrypi/libcamera-apps.git;protocol=https;branch=main \ |
| 12 | file://0001-utils-version.py-use-usr-bin-env-in-shebang.patch \ |
| 13 | " |
| 14 | PV = "1.2.1+git${SRCPV}" |
| 15 | SRCREV = "1c1d1c1a2a86d70cf873edc8bb72d174f037973a" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | DEPENDS = "libcamera libexif jpeg tiff libpng boost" |
| 20 | |
| 21 | PACKAGECONFIG ??= "drm" |
| 22 | PACKAGECONFIG[libav] = "-Denable_libav=true, -Denable_libav=false, libav" |
| 23 | PACKAGECONFIG[drm] = "-Denable_drm=true, -Denable_drm=false, libdrm" |
| 24 | PACKAGECONFIG[egl] = "-Denable_egl=true, -Denable_egl=false, virtual/egl" |
| 25 | PACKAGECONFIG[qt] = "-Denable_qt=true, -Denable_qt=false, qtbase" |
| 26 | PACKAGECONFIG[opencv] = "-Denable_opencv=true, -Denable_opencv=false, opencv" |
| 27 | PACKAGECONFIG[tflite] = "-Denable_tflite=true, -Denable_tflite=false, tensorflow-lite" |
| 28 | |
| 29 | inherit meson pkgconfig |
| 30 | |
| 31 | NEON_FLAGS = "" |
| 32 | NEON_FLAGS:aarch64 = "-Dneon_flags=arm64" |
| 33 | NEON_FLAGS:arm:raspberrypi3 = "-Dneon_flags=armv8-neon" |
| 34 | NEON_FLAGS:arm:raspberrypi4 = "-Dneon_flags=armv8-neon" |
| 35 | EXTRA_OEMESON += "${NEON_FLAGS}" |
| 36 | |
| 37 | # QA Issue: /usr/bin/camera-bug-report contained in package libcamera-apps requires /usr/bin/python3 |
| 38 | do_install:append() { |
| 39 | rm -v ${D}/${bindir}/camera-bug-report |
| 40 | } |