blob: ba873aa997c8c6391e28d3f2a1a14c75fd46589d [file] [log] [blame]
Adriana Kobylak6161f452015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
Brad Bishopc88c37c2015-10-21 20:24:23 -04008inherit obmc-phosphor-chassis-mgmt
Brad Bishopc88c37c2015-10-21 20:24:23 -04009inherit obmc-phosphor-fan-mgmt
10inherit obmc-phosphor-flash-mgmt
11inherit obmc-phosphor-policy-mgmt
12inherit obmc-phosphor-sensor-mgmt
13inherit obmc-phosphor-system-mgmt
Adriana Kobylak6161f452015-10-19 14:15:04 -040014
KennethWilke84f9c742016-02-17 13:24:04 -060015DEPENDS += "glib-2.0 systemd"
Norman Jamesa91766b2016-02-10 11:34:19 -060016RDEPENDS_${PN} += "python-subprocess python-compression libsystemd"
Adriana Kobylak6161f452015-10-19 14:15:04 -040017SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylak6161f452015-10-19 14:15:04 -040018
Adriana Kobylake858b1e2016-02-12 15:23:57 -060019SRCREV = "ad8c3d3b7be6cc5cda80a2f215b40eae16381b09"
Adriana Kobylak6161f452015-10-19 14:15:04 -040020
Brad Bishop59ca1fd2015-10-28 08:13:43 -050021S = "${WORKDIR}"
Adriana Kobylak6161f452015-10-19 14:15:04 -040022
23do_compile() {
Adriana Kobylak75b8b382015-10-29 11:14:29 -050024 oe_runmake -C git
Adriana Kobylak6161f452015-10-19 14:15:04 -040025}
26
27do_install() {
Brad Bishop59ca1fd2015-10-28 08:13:43 -050028 source=${S}/git
29
Adriana Kobylak6161f452015-10-19 14:15:04 -040030 install -d ${D}/${sbindir} ${D}${libdir}
Adriana Kobylak75b8b382015-10-29 11:14:29 -050031 for i in ${source}/bin/*; do
Adriana Kobylak6161f452015-10-19 14:15:04 -040032 install $i ${D}/${sbindir}
33 done
Adriana Kobylak75b8b382015-10-29 11:14:29 -050034 for i in ${source}/lib/*; do
35 install $i ${D}/${libdir}
36 done
Adriana Kobylak6161f452015-10-19 14:15:04 -040037}