blob: 47a98f3aac926ceb0f5a9a773dd7c1ce26e8ca8d [file] [log] [blame]
Brad Bishop08902b02019-08-20 09:16:51 -04001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
Brad Bishop08902b02019-08-20 09:16:51 -040010 "
Brad Bishop6dbb3162019-11-25 09:41:34 -050011SRC_URI[md5sum] = "ad4de38d6ff1ccf3640573e967dfb136"
12SRC_URI[sha256sum] = "031de5ebc44b49992c11633f10aae96da05a85b326aebdffd88ba8c445d23cf4"
Brad Bishop08902b02019-08-20 09:16:51 -040013
14DEPENDS = "coreutils-native"
15
Brad Bishopc68388fc2019-08-26 01:33:31 -040016PROVIDES = "stress"
17RPROVIDES_${PN} = "stress"
18RREPLACES_${PN} = "stress"
19RCONFLICTS_${PN} = "stress"
20
Brad Bishop08902b02019-08-20 09:16:51 -040021inherit bash-completion
22
23do_install() {
24 oe_runmake DESTDIR=${D} install
25}