Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "display dialog boxes from shell scripts" |
| 2 | DESCRIPTION = "Dialog lets you to present a variety of questions \ |
| 3 | or display messages using dialog boxes from a shell \ |
| 4 | script (or any scripting language)." |
| 5 | HOMEPAGE = "http://invisible-island.net/dialog/" |
| 6 | SECTION = "console/utils" |
| 7 | DEPENDS = "ncurses" |
| 8 | LICENSE = "LGPL-2.1" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 10 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 11 | SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz" |
| 12 | SRC_URI[sha256sum] = "ae478fe7d5fca82bcf4b51684641e07d2ee68489d319710fe1e81f41a197bd66" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | # hardcoded here for use in dialog-static recipe |
| 15 | S = "${WORKDIR}/dialog-${PV}" |
| 16 | |
| 17 | inherit autotools-brokensep pkgconfig |
| 18 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 19 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 20 | |
| 21 | PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11" |
| 22 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | EXTRA_OECONF = "--with-ncurses \ |
| 24 | --disable-rpath-hack" |
| 25 | |
| 26 | do_configure() { |
| 27 | gnu-configize --force |
| 28 | sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure |
| 29 | sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure |
| 30 | oe_runconf |
| 31 | } |