Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Enca is an Extremely Naive Charset Analyser" |
| 2 | SECTION = "libs" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame^] | 3 | HOMEPAGE = "https://cihar.com/software/enca/" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 4 | |
| 5 | DEPENDS += "gettext-native" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=24b9569831c46d4818450b55282476b4" |
| 9 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame^] | 10 | SRC_URI = "https://dl.cihar.com/enca/enca-${PV}.tar.gz \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://configure-hack.patch \ |
| 12 | file://dont-run-tests.patch \ |
| 13 | file://configure-remove-dumbness.patch \ |
| 14 | file://makefile-remove-tools.patch \ |
| 15 | file://libenca-003-iconv.patch " |
| 16 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame^] | 17 | SRC_URI[sha256sum] = "75a38ed23bac37cc12166cc5edc8335c3af862adc202f84823d3aef3e2208e47" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | |
| 19 | inherit autotools |
| 20 | |
| 21 | do_configure_prepend() { |
| 22 | # remove failing test which checks for something that isn't even used |
| 23 | sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' ${S}/configure.ac |
| 24 | } |
| 25 | |
| 26 | do_configure_append() { |
| 27 | sed -i s:-I/usr/include::g ${B}/Makefile |
| 28 | sed -i s:-I/usr/include::g ${B}/*/Makefile |
| 29 | } |
| 30 | |
| 31 | do_compile() { |
| 32 | cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c |
| 33 | cd ${B} |
| 34 | oe_runmake |
| 35 | } |
| 36 | |