Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the Apache Thrift RPC system" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=e95cd2f17c70d3180a2b361332319fe0" |
| 4 | |
| 5 | SRC_URI[md5sum] = "c3bc8d9a910d2c9ce26f2ad1f7c96762" |
| 6 | SRC_URI[sha256sum] = "9af1c86bf73433afc6010ed376a6c6aca2b54099cc0d61895f640870a9ae7d89" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | # Use different filename to prevent conflicts with thrift itself |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | PYPI_SRC_URI:append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} += "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | ${PYTHON_PN}-logging \ |
| 15 | ${PYTHON_PN}-six \ |
| 16 | ${PYTHON_PN}-stringold \ |
| 17 | ${PYTHON_PN}-threading \ |
| 18 | " |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 19 | |
| 20 | BBCLASSEXTEND = "native nativesdk" |