Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Supervisor: A Process Control System" |
| 2 | DESCRIPTION = "\ |
| 3 | Supervisor is a client/server system that allows its users \ |
| 4 | to monitorand control a number of processes on UNIX-like \ |
| 5 | operating systems." |
| 6 | HOMEPAGE = "https://github.com/Supervisor/supervisor" |
| 7 | LICENSE = "BSD-4-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e" |
| 9 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "c479c875853e9c013d1fa73e529fd2165ff1ecaecc7e82810ba57e7362ae984d" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
| 12 | PYPI_PACKAGE = "supervisor" |
| 13 | inherit pypi systemd setuptools3 |
| 14 | RDEPENDS_${PN} = "\ |
| 15 | ${PYTHON_PN}-meld3 \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI += "file://supervisord.conf \ |
| 19 | file://supervisor.service \ |
| 20 | " |
| 21 | SYSTEMD_SERVICE_${PN} = "supervisor.service" |
| 22 | |
| 23 | do_install_append() { |
| 24 | install -d ${D}${sysconfdir}/supervisor |
| 25 | install -d ${D}${systemd_system_unitdir} |
| 26 | |
| 27 | install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor |
| 28 | install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir} |
| 29 | } |