Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple DirectMedia Layer truetype font library" |
| 2 | SECTION = "libs" |
| 3 | DEPENDS = "libsdl2 freetype virtual/egl" |
| 4 | LICENSE = "Zlib" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a41cbf59bdea749fe34c1af6d3615f68" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 6 | |
| 7 | SRC_URI = " \ |
| 8 | git://github.com/libsdl-org/SDL_ttf.git;branch=release-2.20.x;protocol=https \ |
| 9 | git://github.com/libsdl-org/freetype.git;branch=VER-2-12-1-SDL;destsuffix=git/external/freetype;name=freetype;protocol=https \ |
| 10 | git://github.com/libsdl-org/harfbuzz.git;branch=2.9.1-SDL;destsuffix=git/external/harfbuzz;name=harfbuzz;protocol=https \ |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 11 | file://0001-freetype-Fix-function-signatures-to-match-without-ca.patch;patchdir=external/harfbuzz \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 12 | file://automake_foreign.patch \ |
| 13 | " |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 14 | SRCREV = "89d1692fd8fe91a679bb943d377bfbd709b52c23" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 15 | SRCREV_freetype = "6fc77cee03e078e97afcee0c0e06a2d3274b9a29" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 16 | SRCREV_harfbuzz = "43931e3e596c04044861770b831c8f9452e2d3b0" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 17 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 18 | SRCREV_FORMAT .= "_freetype_harfbuzz" |
| 19 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools pkgconfig features_check |
| 23 | |
| 24 | # links to libGL.so |
| 25 | REQUIRED_DISTRO_FEATURES += "opengl" |
| 26 | |
| 27 | do_configure:prepend() { |
| 28 | # Removing these files fixes a libtool version mismatch. |
| 29 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" |
| 30 | |
| 31 | for i in ${MACROS}; do |
| 32 | rm -f ${S}/acinclude/$i |
| 33 | done |
| 34 | } |
| 35 | ASNEEDED = "" |