blob: 4c472f8ef6fa7310274915ea754851aa0eeb8458 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
Andrew Geissler220dafd2023-10-04 10:18:08 -050011SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Patrick Williams169d7bc2024-01-05 11:33:25 -060012 file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data.patch \
13 file://CVE-2023-6277-At-image-reading-compare-data-size-of-some-tags-data-2.patch \
14 file://CVE-2023-6277-Apply-1-suggestion-s-to-1-file-s.patch \
Andrew Geissler220dafd2023-10-04 10:18:08 -050015 "
Andrew Geissler517393d2023-01-13 08:55:19 -060016
Andrew Geissler220dafd2023-10-04 10:18:08 -050017SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a"
Andrew Geissler517393d2023-01-13 08:55:19 -060018
19# exclude betas
20UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
21
Andrew Geissler8f840682023-07-21 09:09:43 -050022CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue"
Andrew Geissler517393d2023-01-13 08:55:19 -060023
24inherit autotools multilib_header
25
26CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
27
28PACKAGECONFIG ?= "cxx jpeg zlib lzma \
29 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
30
31PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
32PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
33PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
34PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
35PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
36PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
Patrick Williams864cc432023-02-09 14:54:44 -060037PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
38PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
Andrew Geissler517393d2023-01-13 08:55:19 -060039
40# Convert single-strip uncompressed images to multiple strips of specified
41# size (default: 8192) to reduce memory usage
42PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
43
44# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
45PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
46
47# Control picking up YCbCr subsample info. Disable to support files lacking
48# the tag
49PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
50
51# Support a mechanism allowing reading large strips (usually one strip files)
52# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
53PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
54
55PACKAGES =+ "tiffxx tiff-utils"
56FILES:tiffxx = "${libdir}/libtiffxx.so.*"
57FILES:tiff-utils = "${bindir}/*"
58
59do_install:append() {
60 oe_multilib_header tiffconf.h
61}
62
63BBCLASSEXTEND = "native nativesdk"