Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Simple Python wrapper around the OpenSSL library" |
| 2 | HOMEPAGE = "https://pyopenssl.org/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 5 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 6 | DEPENDS += "openssl python3-cryptography" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 8 | SRC_URI[sha256sum] = "cabed4bfaa5df9f1a16c0ef64a0cb65318b5cd077a7eda7d6970131ca2f41a6f" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 9 | |
| 10 | PYPI_PACKAGE = "pyOpenSSL" |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | PACKAGES =+ "${PN}-tests" |
| 14 | FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test" |
| 15 | |
| 16 | RDEPENDS:${PN}:class-target = " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 17 | python3-cryptography \ |
| 18 | python3-six \ |
| 19 | python3-threading \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 20 | " |
| 21 | RDEPENDS:${PN}-tests = "${PN}" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |