Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Utilities for extracting and viewing files in .zip archives" |
| 2 | HOMEPAGE = "http://www.info-zip.org" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=94caec5a51ef55ef711ee4e8b1c69e29" |
| 6 | PE = "1" |
| 7 | PR = "r5" |
| 8 | |
| 9 | SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz \ |
| 10 | file://avoid-strip.patch \ |
| 11 | file://define-ldflags.patch \ |
| 12 | file://06-unzip60-alt-iconv-utf8_CVE-2015-1315.patch \ |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 13 | file://cve-2014-9636.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | file://09-cve-2014-8139-crc-overflow.patch \ |
| 15 | file://10-cve-2014-8140-test-compr-eb.patch \ |
| 16 | file://11-cve-2014-8141-getzip64data.patch \ |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 17 | file://CVE-2015-7696.patch \ |
| 18 | file://CVE-2015-7697.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | SRC_URI[md5sum] = "62b490407489521db863b523a7f86375" |
| 22 | SRC_URI[sha256sum] = "036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37" |
| 23 | S = "${WORKDIR}/unzip60" |
| 24 | |
| 25 | # Makefile uses CF_NOOPT instead of CFLAGS. We lifted the values from |
| 26 | # Makefile and add CFLAGS. Optimization will be overriden by unzip |
| 27 | # configure to be -O3. |
| 28 | # |
| 29 | EXTRA_OEMAKE += "STRIP=true LF2='' \ |
| 30 | 'CF_NOOPT=-I. -Ibzip2 -DUNIX ${CFLAGS}'" |
| 31 | |
| 32 | export LD = "${CC}" |
| 33 | LD_class-native = "${CC}" |
| 34 | |
| 35 | do_compile() { |
| 36 | oe_runmake -f unix/Makefile generic |
| 37 | } |
| 38 | |
| 39 | do_install() { |
| 40 | oe_runmake -f unix/Makefile install prefix=${D}${prefix} |
| 41 | install -d ${D}${mandir} |
| 42 | mv ${D}${prefix}/man/* ${D}${mandir} |
| 43 | rmdir ${D}${prefix}/man/ |
| 44 | } |
| 45 | |
| 46 | inherit update-alternatives |
| 47 | |
| 48 | ALTERNATIVE_PRIORITY = "100" |
| 49 | |
| 50 | ALTERNATIVE_${PN} = "unzip" |
| 51 | ALTERNATIVE_LINK_NAME[unzip] = "${bindir}/unzip" |
| 52 | |
| 53 | BBCLASSEXTEND = "native" |