blob: 966ff86dee88359a09ebe6118a863044f719ee70 [file] [log] [blame]
Brad Bishop2d39a062019-10-28 08:33:36 -04001SUMMARY = "Mycroft Skill Manager, in python!"
2HOMEPAGE = "https://github.com/MycroftAI/mycroft-skills-manager"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa"
5
Andrew Geisslerd688a012020-09-18 13:36:00 -05006SRC_URI[md5sum] = "cf1fc0d1d86af68003cae53c71ec6288"
7SRC_URI[sha256sum] = "a502aee54917cd394217b31c977a1ba3d9541a0120e0a045c49fd77b328e4a29"
Brad Bishop2d39a062019-10-28 08:33:36 -04008
9inherit pypi setuptools3
10
Patrick Williamsb542dec2023-06-09 01:26:37 -050011RDEPENDS:${PN} += " \
Brad Bishop2d39a062019-10-28 08:33:36 -040012 python3-appdirs \
Patrick Williamsb542dec2023-06-09 01:26:37 -050013 python3-git \
14 python3-fasteners \
15 python3-io \
16 python3-json \
17 python3-lazy \
18 python3-monotonic \
19 python3-multiprocessing \
20 python3-pako \
21 python3-pyyaml \
22 python3-requests \
Brad Bishop2d39a062019-10-28 08:33:36 -040023"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025do_install:append() {
Brad Bishop2d39a062019-10-28 08:33:36 -040026 # Stop this from being installed
27 rm -rf ${D}/usr/share
28}