Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | SUMMARY = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 2 | HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 3 | LICENSE = "LGPL-2.1-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
| 5 | SECTION = "net" |
| 6 | |
| 7 | DEPENDS = "file" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame^] | 10 | SRC_URI[sha256sum] = "9e7023a151120060d2806a6ea4c13ca9933ece4eacfc5c9464d20edddb76b0a0" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | |
| 12 | inherit autotools lib_package pkgconfig gettext |
| 13 | |
| 14 | CFLAGS += "-pthread -D_REENTRANT" |
| 15 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 16 | EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../ --enable-largefile" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | |
| 18 | PACKAGECONFIG ?= "curl https" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 19 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| 21 | PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| 22 | |
| 23 | do_compile:append() { |
| 24 | sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |